Haynes Forums

Haynes Forums (http://www.haynes.co.uk/forums/index.php)
-   Engine/transmission (http://www.haynes.co.uk/forums/forumdisplay.php?f=6)
-   -   ST170 Anyone? (http://www.haynes.co.uk/forums/showthread.php?t=13989)

CarlW 2nd November 2016 12:52 PM

ST170 Anyone?
 
Hi All,

Anyone fitted the ST170 2.0L Zetec in a Haynes?


Cheers,

flyerncle 2nd November 2016 03:54 PM

"Mark" many moons ago, Stockton-Darlington area,one of the very first members here.

vmax1974 2nd November 2016 09:05 PM

Mark and david_17 both local to me fitted the st170 lump neither are active but their build threads should still be viewable

alga 7th November 2016 12:42 AM

I have an ST170 in my garage as a swap for my Silvertop, it's been sitting there over a year tbh. Anything in particular I could help you with?

CarlW 7th November 2016 07:17 AM

Hi ya,

Its more to do with fitting it in the chassis, most seem to cut the top rail to miss the inlet?

twinturbo 8th November 2016 08:35 PM

Andy ( Spud ) who used to run Saturn had a 170. Quick car :)

Was mark's car not an MNR or other and not a Haynes, can't remember as it's 5+ years since I met him.

flyerncle 9th November 2016 11:04 AM

You are thinking of Steve who had the MNR and Spud,s car was a 2 ltr Zetec with bike carbs and cams in possibly 200bhp,it went very well.

twinturbo 9th November 2016 06:52 PM

Ahh, mixing all three up ;) met them all at SSC once upon a time.

TT


All times are GMT +1. The time now is 08:51 AM.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.