Haynes Forums  

Go Back   Haynes Forums > Haynes Roadster Forums > Announcements
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #581  
Old 22nd April 2015, 05:48 PM
Stot's Avatar
Stot Stot is offline
Senior Member
 
Join Date: Nov 2012
Location: Wolverhampton
Posts: 750
Default

Made some people smile, me included.

Cheers
Stot
__________________
1.6 Mazda B6 : Garrett TBO339 : 420cc WRX Injectors : FMIC : Microsquirt V3 : LC-2 Wideband : Toyota COP
Build Started Jan 2013 : OTR Aug 2014 : Build Pictures
Reply With Quote
  #582  
Old 28th April 2015, 09:21 AM
Stot's Avatar
Stot Stot is offline
Senior Member
 
Join Date: Nov 2012
Location: Wolverhampton
Posts: 750
Default

I have been trying to get a grip on my fuel usage over the last couple of weeks as I fixed my fuel guage recently.

Running 8psi of boost on a 1.6 engine I'm getting 150miles a tank, or 25.5mpg. Same as my DD so I'm happy enough with that!

Cheers
Stot
__________________
1.6 Mazda B6 : Garrett TBO339 : 420cc WRX Injectors : FMIC : Microsquirt V3 : LC-2 Wideband : Toyota COP
Build Started Jan 2013 : OTR Aug 2014 : Build Pictures
Reply With Quote
  #583  
Old 29th April 2015, 07:06 AM
rpjg1975 rpjg1975 is offline
Senior Member
 
Join Date: Jun 2009
Location: School Aycliffe, County Durham
Posts: 556
Default

Can't complain at that.....not like the roadster is a super slippery shape!
Reply With Quote
  #584  
Old 9th May 2015, 10:58 AM
CTWV50's Avatar
CTWV50 CTWV50 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 1,297
Default

Quote:
Originally Posted by Stot View Post
Slow progress, but I shortened the pickup pipe and have an oil return and drain plug. Whoohoo.



Cheers
Stot
Where's your drain plug from? And what's the spec? Trying to find something on ebay but failing.

Thanks
Reply With Quote
  #585  
Old 9th May 2015, 11:57 AM
Stot's Avatar
Stot Stot is offline
Senior Member
 
Join Date: Nov 2012
Location: Wolverhampton
Posts: 750
Default

Quote:
Originally Posted by CTWV50 View Post
Where's your drain plug from? And what's the spec? Trying to find something on ebay but failing.

Thanks
I recycled the original drain plug. Chopped it out with an angle grinder and turned it down on the lathe.

The guy that welded mine up hated it and said never again.

Cheers
Stot
__________________
1.6 Mazda B6 : Garrett TBO339 : 420cc WRX Injectors : FMIC : Microsquirt V3 : LC-2 Wideband : Toyota COP
Build Started Jan 2013 : OTR Aug 2014 : Build Pictures
Reply With Quote
  #586  
Old 9th May 2015, 02:39 PM
Stot's Avatar
Stot Stot is offline
Senior Member
 
Join Date: Nov 2012
Location: Wolverhampton
Posts: 750
Default

Added some bonnet vents. With the turbo my normal running temps are 103-110c even with a full mx5 reroute out the back so hopefully these will help a bit.



Cheers
Stot
__________________
1.6 Mazda B6 : Garrett TBO339 : 420cc WRX Injectors : FMIC : Microsquirt V3 : LC-2 Wideband : Toyota COP
Build Started Jan 2013 : OTR Aug 2014 : Build Pictures
Reply With Quote
  #587  
Old 12th May 2015, 08:40 PM
Stot's Avatar
Stot Stot is offline
Senior Member
 
Join Date: Nov 2012
Location: Wolverhampton
Posts: 750
Default

So THATS what that rattle was....



Glad it only took 45 mins to change.

If you get a china manifold, get a good quality pressed stainless gasket for it. The China one was aluminum is seems.

Cheers
Stot
__________________
1.6 Mazda B6 : Garrett TBO339 : 420cc WRX Injectors : FMIC : Microsquirt V3 : LC-2 Wideband : Toyota COP
Build Started Jan 2013 : OTR Aug 2014 : Build Pictures
Reply With Quote
  #588  
Old 13th May 2015, 07:27 PM
CTWV50's Avatar
CTWV50 CTWV50 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 1,297
Default

I'll have to buy a fitting then, I wish I had a lathe.

Quote:
Originally Posted by Stot View Post
Intercooler and merc rad just about fit in the nose with a fan pulling from behind.


What car is the rad and intercooler from? They look a neat solution.

190E?

"The Mercedes 190E radiator that many of the Haynes Roadster guys use has an oil cooler built in.

eBay Item

Its upside down in those ebay pictures, the red caps are on the oil filter in/out.

Cheers
Stot"

Last edited by CTWV50 : 13th May 2015 at 07:47 PM.
Reply With Quote
  #589  
Old 13th May 2015, 07:29 PM
CTWV50's Avatar
CTWV50 CTWV50 is offline
Senior Member
 
Join Date: Aug 2010
Posts: 1,297
Default

Quote:
Originally Posted by Stot View Post
Added some bonnet vents. With the turbo my normal running temps are 103-110c even with a full mx5 reroute out the back so hopefully these will help a bit.



Cheers
Stot
Have you thought about waterless coolant or maybe removing the thermostat? These are things I'm considering.
Reply With Quote
  #590  
Old 14th May 2015, 09:41 AM
Stot's Avatar
Stot Stot is offline
Senior Member
 
Join Date: Nov 2012
Location: Wolverhampton
Posts: 750
Default

Quote:
Originally Posted by CTWV50 View Post
I'll have to buy a fitting then, I wish I had a lathe.



What car is the rad and intercooler from? They look a neat solution.

190E?

"The Mercedes 190E radiator that many of the Haynes Roadster guys use has an oil cooler built in.

eBay Item

Its upside down in those ebay pictures, the red caps are on the oil filter in/out.

Cheers
Stot"
Yeah the rad is a 190E radiator. The core is exactly the same size as the intercooler. I have ducting in the nose too so that air cant go around the intercooler.

My temps still run at upto 110c. I have a full reroute in place and the fan switch is at the thermostat. In traffic the fan will come on and bring it back down to 102. It seems my fan switch actually comes on at 110 and off at 102 rather than 97/92 as its supposed to. Its new too.

Im going to try running the fan off the ECU for a while at a lower temp to see if that helps but It will probably just end up with the fan on permanently. If not ill try without the thermostat to see if it overcools then but really its when im going 70-80mph on the motorway im getting the most heat into the engine, its sitting at 4000 rpm so whenever you apply some throttle its into boost.

I think the radiator just isnt removing enough heat so I have a spare 190 radiator with a hole in it and Im thinking of sending that off to have an aluminium twin or tripple core copy made up if nothing else helps.

Cheers
Stot
__________________
1.6 Mazda B6 : Garrett TBO339 : 420cc WRX Injectors : FMIC : Microsquirt V3 : LC-2 Wideband : Toyota COP
Build Started Jan 2013 : OTR Aug 2014 : Build Pictures
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 04:12 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.