Haynes Forums  

Go Back   Haynes Forums > Haynes Roadster Forums > Running gear
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 18th September 2019, 02:44 PM
Andrew08 Andrew08 is offline
Junior Member
 
Join Date: Sep 2019
Posts: 2
Default Saturn MX5 - Rear Suspension Camber?

I am in the early stages of building my MX5 based car. I am following the Saturn plans and available online amendments etc. I am using a MK2 donor.

Having built my chassis and wishbones and starting to fit things up I am experiencing a lot of negative camber at the rear. I fabricated using the threaded adjusters on my lower wishbones, but even with these screwed almost fully in (so much that I cannot fit a lock nut) I still have too much negative camber. I haven't measured it, but visually it looks too much.

Is this a known problem? I've searched the various forums but not come up with anything conclusive. I'm at the stage where I am contemplating spacing out my top wishbone mounts by around 5-10mm to bring it back to a more neutral position, but then I'm worried about upsetting other aspects of the suspension and drive system.

I've checked and double checked what I have built against the Saturn plans and everything seems to be about right dimensionally.

If anyone has the correct dimensions for the rear wishbones and the chassis pick-up points I'd really appreciate it, maybe I have old or out of date information?

I am just lost as to where the problem is, any help much appreciated. Thanks.
Reply With Quote
  #2  
Old 4th October 2019, 10:25 AM
Andrew08 Andrew08 is offline
Junior Member
 
Join Date: Sep 2019
Posts: 2
Default

Hi, just to follow up on this a little (and hopefully provoke some replies).

I have double checked all measurements again against the various available sources and everything seems to be correct (or at least within a small tolerance). However, with the adjusters screwed almost fully in I have around 5 degrees negative camber on one side and 6 degrees on the other side. Surely this cannot be correct?

I am at the stage of removing the top wishbone brackets and spacing them off the chassis by around 12-15mm, that will bring the camber back to neutral and allow me a little range on my adjusters.

Unless I have gone badly wrong somewhere then this problem must have come up before?

Any help much appreciated, thanks.
Reply With Quote
  #3  
Old 5th October 2019, 11:37 PM
garyout garyout is offline
Senior Member
 
Join Date: Feb 2016
Location: Gosport Hampshire
Posts: 141
Default

Evening Andrew


Not sure if they are the same but I am building a Talon chassis the back is modified for custom diff carrier but I think the wishbones are the same dimensions. my pick ups for the top wish bones are on the outer edge of the cradle I haven't measured the camber yet but it looks ok.


Gary
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 12:28 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.