Haynes Forums  

Go Back   Haynes Forums > Haynes Roadster Forums > Announcements
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #501  
Old 27th August 2018, 08:04 PM
garyout garyout is offline
Senior Member
 
Join Date: Feb 2016
Location: Gosport Hampshire
Posts: 122
Default

oh!!!! I must admit I've done the same but it was the throttle cable that wore that one welding up a stabiliser bracket on a mini.

have you decided on charger or turbo yet?

Gary
Reply With Quote
  #502  
Old 27th August 2018, 08:09 PM
norton norton is offline
Senior Member
 
Join Date: May 2015
Posts: 425
Default

Turbo for sure, a charger is harder in my eyes however this is a long way off. How's yours doing?
Reply With Quote
  #503  
Old 27th August 2018, 10:54 PM
garyout garyout is offline
Senior Member
 
Join Date: Feb 2016
Location: Gosport Hampshire
Posts: 122
Default

slow mate bloody slow messed about with handbrake cables Saturday got to make some different brackets, I have now sussed out brake and clutch pedal return I used land rover 90 ones designed for it


I'm trying to focus on one job at a time


Gary
Reply With Quote
  #504  
Old 27th August 2018, 10:57 PM
norton norton is offline
Senior Member
 
Join Date: May 2015
Posts: 425
Default

I didnít use brake or clutch returns beyond the cylinder pressures/internal springs and they both feel great. The throttle pedal is a sod though. It needs more return spring pressure as well as a decent stop.

If you ever want to pop over to laugh at mine youíre very welcome
Reply With Quote
  #505  
Old 1st September 2018, 06:22 PM
garyout garyout is offline
Senior Member
 
Join Date: Feb 2016
Location: Gosport Hampshire
Posts: 122
Default

will have to take you up on your offer and its like ways

Gary
Reply With Quote
  #506  
Old 5th January 2019, 03:07 PM
norton norton is offline
Senior Member
 
Join Date: May 2015
Posts: 425
Default

I had a break. I became a bit miffed due to my scuttle top going concave and not being able to figure out why my ecu was losing crank signal.

I still haven't fixed these issues but to bump start my motivation I thought I'd jump ahead and start on the bit I'm most excited about.









Its a TD04L from an Impreza and applying one to an MX5 motor is a well trodden path I'll follow. I went with an external wastegate as I want to clock this in such a way as to make the installation a lot cleaner and to re use the original wastegate would mean welding threaded bosses to the compressor housing. I didn't realise the external gate was so large but that shouldn't be a problem. My exhaust was built with this in mind so a simple link tube should be easy to make to link it all up. Then its time to mount an intercooler, pipes, recirc valve, oil feed and drain plus some coolant pipes to the turbo core and then we're sorted!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 12:24 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.