Haynes Forums  

Go Back   Haynes Forums > Haynes Roadster Forums > Engine/transmission
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 8th May 2018, 05:12 AM
RandyBMC RandyBMC is offline
Junior Member
 
Join Date: Sep 2017
Posts: 19
Default OBP KC003 Pedal Box question

Hello all,

I just received an OBPKC003 pedal box, and there is no linkage for the throttle pedal. Has anyone used this set up? I am using an MX5 (1993) for a donor.

The last page of my build shows photos and poses the question. See here:

http://locostusa.com/forums/viewtopi...3774&start=195

Help! Thanks in advance.
Reply With Quote
  #2  
Old 10th May 2018, 12:54 PM
MikeB MikeB is offline
Senior Member
 
Join Date: Apr 2007
Location: Nr Wellingborough
Posts: 512
Default

I had to modify mine, wasn't happy just couldn't see how I could get it work as was
Untitled by mjb22001, on Flickr

I raised the pivot point and welded a bit on the bottom so the cable pulls from the bottom. not sure how it was designed originally, there may be better solutions but I couldn't make it work in my car as was
__________________
Build Cost so far £xxx (Given up adding it up) - She Starts!! Build Thread Here:
http://www.haynes.co.uk/forums/showthread.php?t=5501
Reply With Quote
  #3  
Old 13th May 2018, 04:32 PM
RandyBMC RandyBMC is offline
Junior Member
 
Join Date: Sep 2017
Posts: 19
Default

Thanks Mike - I worked out a solution. We'll see if it works! I posted photos of the start in my build thread (see my signature).
Reply With Quote
  #4  
Old 14th May 2018, 04:26 PM
RandyBMC RandyBMC is offline
Junior Member
 
Join Date: Sep 2017
Posts: 19
Default

Buttoned up the pedal solution today. Take a look at my build log's last page. Input is welcome!
Reply With Quote
  #5  
Old 15th May 2018, 12:14 PM
MikeB MikeB is offline
Senior Member
 
Join Date: Apr 2007
Location: Nr Wellingborough
Posts: 512
Default

Looks great.

Annoying that for an expensive item there isn't a stock solution to attaching a throttle cable.
__________________
Build Cost so far £xxx (Given up adding it up) - She Starts!! Build Thread Here:
http://www.haynes.co.uk/forums/showthread.php?t=5501
Reply With Quote
  #6  
Old 15th May 2018, 02:05 PM
RandyBMC RandyBMC is offline
Junior Member
 
Join Date: Sep 2017
Posts: 19
Default

Thanks - totally agree! I requested help on it from Rallynuts and OBP, and just got the PDF of them drilling a hole in the end of the pedal. Wilwood has a complete bell crank bolt-on solution. As you said, for the money, I would've hoped even if I had to pay a little more I could've gotten a bolt-on solution.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 12:20 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.