Haynes Forums  

Go Back   Haynes Forums > Haynes Roadster Forums > Engine/transmission
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 4th January 2014, 09:52 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Z20LET into a Haynes Roadster

Its time i posted up my build diary for fitting my Astra turbo engine into my Haynes Roadster, seems to be one of the next upgrades people might start doing.

Firstly it started out with a NA 2.0 16V Vauxhall Engine C20XE so the conversion is a little easier for me. The Z20LET is a 2.0 16V Turbo engine, very similar to the C20LET which is the Turbo verson of the C20XE. This all means that the existing bellhousing and engine mounts all fit straight on, although the passenger side mount needs modifying for the boost pipe to go through.

Picked up a running engine and started stripping it all of bits i wont need anymore....




Its very busy this end and i dont like it !


Thats better.

Last edited by Ben_Copeland : 5th January 2014 at 05:51 PM.
Reply With Quote
  #2  
Old 4th January 2014, 09:53 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Next Step..

Next i need to replace the throttle body, the TB on the Z20LET is fly-by-wire and i cant run that on MS2 (or cant be bothered to work out how)


I've bought a throttle body of a X20XEV which is effectively a NA version of my engine (2.0L 16v from a vectra/astra etc)
Its fits straight on and converts to cable throttle, its slightly larger which cant be a bad thing.

I actually ended up turning this round 180 degrees so it fits better.
Reply With Quote
  #3  
Old 4th January 2014, 09:54 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default On Going...

Next is to remove the sump which is massive and isnt going to fit, also i removed the balance shafts that are mounted over the crank. These sap power and also add a massive weight to the bottom of the engine. Unfortunately they are oil feed from the crank bearing caps, so they need tapping and filling so the oil doesnt come out !


Tapped and grub screwed.



Caps back in.
The downside of removing the balance shafts is they also act as crank girdle so you either need to find a X20XEV crank girdle that doesnt have balance shafts (early one maybe) or make your own.
Reply With Quote
  #4  
Old 4th January 2014, 09:54 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Yep, Theres More....

Friend of mine sent me this to play with as it didnt fit with his sump....


Unfortunately i ended up having to cut it up as it didnt fit with my sump either, but strips are better than nothing.

I used the XE windage tray just cutting holes where the girdle stuck through.

I'm fitting a Caterham Alloy Sump from my XE engine, which just fits but ive had to modify the pickup pipe, using the head of the XE one with the oil pump end from the ZLET engine. Its a bit of a faff to sort and unfortunately i didnt take a picture, but just make sure its got no leaks! I also had to drill out the sump bolt holes because they are m8 instead of m6 like the XE, but easy enough to do.

I then started checking over the turbo. It had been fitted with a VXR turbo and wastegate which is a popular power upgrade, pretty much a direct swap and good for about 300bhp.

I had noticed the oil feed pipe was oily and one of the connections was at an angle..

Dumb Arse!!!

Took it apart and luckily i rescued it with a small file and a bit of patience....

Better.
Reply With Quote
  #5  
Old 4th January 2014, 09:55 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Still Going.....

I took the exhaust manifold off to replace the gasket and found 2 stripped threads in the head and rusted studs/nuts
They'll all need replacing before the turbo manifold can go back on... BALLS.


I helicoiled the 2 threads in the head and replaced all the studs. While the exhaust manifold was off i painted the block black to get rid of the Red as it didnt match which my cars colours.


Also the turbo return pipe was held in with a bolt and self tapping screw and glue. WTF, how difficult would it of been to find another bolt for it. Again, luckily! i managed to remove the glue and cleaned up the bolt hole. Replaced the gaskets and bolted it all back up.


I also binned the dump valve bits and fitted a nice alloy recirculation valve, back to standard...ish.

Last edited by Ben_Copeland : 4th January 2014 at 09:59 AM.
Reply With Quote
  #6  
Old 4th January 2014, 10:02 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Wow, Still Going......

Moved back over to the inlet side and decided to check the injectors. As i thought standard, and not suitable for VXR turbo power.

I had some Rover 800 Turbo injectors lurking in the garage which are a direct swap, a lot more cc's. So i sent them off to Mr Injector to get them cleaned and check etc.
380cc i believe @ 3 bar



Refitted the rail. Done

Got a bit of a painting bug from doing the engine block so decided to do the camcover.

Rubbed down


Primed with a etch primer


Undercoated white
Reply With Quote
  #7  
Old 4th January 2014, 10:03 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Going On.......

Top coated with DynaRod orange and then lacquered to make it oil/petrol/heat resistant.


Didnt like the standard yellow oil cap, so rubbed that down and painted it black.


Also painted the bolts black too ;-)


Fitted and finished with a Black VXR spark plug cover.
Reply With Quote
  #8  
Old 4th January 2014, 10:05 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Loosing The Will to Live?

Time to strip the old engine out of my car. Ive done this a couple of times so should be easy enough.

Fully assembled car including nosecone etc.

Ok no nosecone in this picture...

To engine out on the bench in 1hr 15mins... not bad for an evening after work.


New engine hanging ready to go in.


Engine in and bolted up to the gearbox. Driver side engine mount in and bolted up. Just need to modify the passenger mount to allow the bottom boost pipe to pass through it.


Forgot to say: the clutch is ford galaxy 2.8 friction and Vauxhall pressure plate. Using alloy bellhousing and type 9 box
Reply With Quote
  #9  
Old 4th January 2014, 10:06 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Given Up Now......?

Jumped forwards a bit to fitting the radiator and intercooler.


Next i made up some mountings for the fans, i couldnt get one big fan into the space behind the radiator so went for 2 smaller ones instead.


Radiator is a Honda Civic alloy racing one i bought off ebay and intercooler is a universal alloy one from ebay. Both cost about 75 each

Needed to change the Inlet Temperature Sensor, but couldn't find one that bolted straight into the manifold, so i had to buy an adapter and tap that so the sensor could fit inside.


Went to refit the steering column extension, but it fouls slightly on the inlet manifold so i've had to put an extra joint in and rosejoint to support it.

Still waiting on some nuts to fit it in place.
Reply With Quote
  #10  
Old 4th January 2014, 10:08 AM
Ben_Copeland's Avatar
Ben_Copeland Ben_Copeland is offline
Senior Member
 
Join Date: Feb 2009
Posts: 288
Default Nearly There.....

Next up is the alternator bracket, its one i made for the XE engine so ive reused it and it bolts up in the same place just needed spacing off the engine slightly as it fouled on the cambelt cover.
The adjuster is made from 2 rosejoints, one right hand and one left hand thread with matching threaded bosses welded together with a nut between them. Picture speaks a thousand words...


Next i managed to source a belt and new pulley for the alternator that matched the crank pulley.


Bought some silicone hose and joiners just before xmas and so i started fitting it all. Got a big list of pipework and connectors that i still need to get, but its nearly there.
\

I've also started to tidy up the wiring and using all the OEM connectors i can find.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 10:23 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.